読者です 読者をやめる 読者になる 読者になる

CentOS 5.2 の mysql-server

CentOS 5.2 の mysql-server が perl-DBD-MySQL 3.006 に依存しててはまった。

perl-DBD-mysql.x86_64 の最新版は 4.007 なんだけど、mysql-server + perl-DBD-MySQL 3.006 が入っているとコンフリクト起こしてインストール or アップグレード出来ない。

CentOS 自体、安定板 RedHot みたいな位置づけなんだから、ふざけるなっと思ったけど、

追記

コンフリクトじゃなくてファイルのバッティング

sudo rpm -ivh --force /var/cache/yum/dag/packages/perl-DBD-mysql-4.007-1.el5.rf.x86_64.rpm

こんな感じで強制的にインストールしちゃえば古いの上書き出来るの思い出した。